check-fetch-times.php Version 1.55 - 30-Jan-2024

Website PHP information

Webserver OS: Linux raspberrypi 5.15.84-v8+ #1613 SMP PREEMPT Thu Jan 5 12:03:08 GMT 2023 aarch64
PHP Version: 7.4.33 built for Linux
PHP cmd location: /usr/bin/php
Document root: /var/www/html
Template root: /var/www/html
allow_url_fopen = ON
allow_url_include = off
request_order = GP
Stream support for http is available
Stream support for https is available
Streams supported: compress.zlib, data, file, ftp, ftps, glob, http, https, phar, php
Socket transports: ssl, tcp, tls, tlsv1.0, tlsv1.1, tlsv1.2, tlsv1.3, udg, udp, unix
..loaded 131 version descriptors for Base-USA.
..loaded 13 version descriptors for WCT-plugin.
Included Settings.php time=0.008 secs.

..fetching recent version information.
RC=200, bytes=100649
Data age=1231171 sec 'Mon, 01 Apr 2024 19:55:21 GMT'
Wrote 100649 bytes to ./cache/template-version-info.txt successfully.
..loaded 668 version descriptors from ./cache/template-version-info.txt file.

Version information for selected Common Files, Deprecated, Base-USA, WCT-plugin (for WeatherCat weather software) key template files

Note: only selected key template files are checked with this script. Files with customary user modifications (Settings.php, Settings-weather.php, top.php, header.php, menubar.php, footer.php, most wx...php files, etc.) and graphics and weather tags files are NOT checked as they either do not contain version information or they are expected to be different from the distribution versions due to normal website customization.
The Recommend column indicates how the file should be handled. Mouse over a recommendation line to see additional information in a tooltip.

Script
Origin
Script
Name
Installed Script
Version Status
RecommendRelease Script
Version
Installed Script
Version
Installed Script Internal
Version Description
USAadvforecast2.phpCurrent  V5.19 - 2022-12-27V5.19 - 2022-12-27advforecast2.php (JSON) - V5.19 - 27-Dec-2022
Commonajax-dashboard.phpNeed update to
V1.34 - 2023-04-03
ReplaceV1.34 - 2023-04-03V1.33 - 2023-02-07ajax-dashboard.php - Version 1.33 - 07-Feb-2023 - Multilingual
Commonajax-gizmo.phpCurrent  V1.15 - 2022-12-27V1.15 - 2022-12-27ajax-gizmo.php V1.15 - 27-Dec-2022 - Multilingual
WCT-pluginajaxWCTwx.jsCurrent  V3.05 - 2012-08-03V3.05 - 2012-08-033.05 - 03-Aug-2012 -- fixed NaN display for feelslike temperature
Deprecatedatom-advisory.phpOk to delete from website.Deleteatom-advisory.php is deprecated.
Deprecatedatom-top-warning.phpOk to delete from website.Deleteatom-top-warning.php is deprecated.
Commoncheck-fetch-times.phpNeed update to
V1.56 - 2024-03-16
ReplaceV1.56 - 2024-03-16V1.55 - 2024-01-30check-fetch-times.php Version 1.55 - 30-Jan-2024
Commoncommon.phpCurrent  V1.14 - 2022-12-27V1.14 - 2022-12-27common.php - Version 1.14 - 27-Dec-2022
USADualImage.phpFile not installed  V1.04 - 2022-04-06DualImage.php file not found.
USAfloatTop.jsCurrent  Vn/a - 2008-03-18Vn/a - n/a(not specified)
Commonflyout-menu.phpCurrent  V1.10 - 2022-12-27V1.10 - 2022-12-27flyout-menu.php (ML) Version 1.10 - 27-Dec-2022
WCT-plugingen-WCTtags.phpCurrent  V1.00 - 2012-03-24V1.00 - 2012-03-24gen-WCTtags.php - V1.00 - 24-Mar-2012
Commonget-metar-conditions-inc.phpNeed update to
V1.22 - 2024-03-08
ReplaceV1.22 - 2024-03-08V1.21 - 2023-01-03get-metar-conditions-inc.php - Version 1.21 - 03-Jan-2023
Commonget-USNO-sunmoon.phpCurrent  V3.05 - 2022-12-27V3.05 - 2022-12-27get-USNO-sunmoon.php - Version 3.05 - 27-Dec-2022
Commonget-UV-forecast-inc.phpCurrent  V1.09 - 2021-02-12V1.09 - 2021-02-12get-UV-forecast-inc.php V1.09 - 12-Feb-2021
USAGR3-radar-inc.phpCurrent  V1.05 - 2015-08-12V1.05 - 2015-08-121.05 - 12-Aug-2015 - http://saratoga-weather.org/scripts.php -->
USAhanis_min.jsCurrent  V4.29 - 2020-04-28V4.29 - 2020-04-284.29 - 28-Apr-2020 - https://www.ssec.wisc.edu/hanis/index.html
Commoninclude-metar-display.phpNeed update to
V1.08 - 2024-03-08
ReplaceV1.08 - 2024-03-08V1.07 - 2022-12-27include-metar-display.php - Version 1.07 - 27-Dec-2022
Commoninclude-style-switcher.phpCurrent  V1.21 - 2021-11-29V1.21 - 2021-11-291.21 - 29-Nov-2021 - add SameSite=Lax to all cookies
Commoninclude-wxstatus.phpCurrent  V1.13 - 2022-01-18V1.13 - 2022-01-181.13 - 18-Jan-2022 - fixes for PHP 8.1 errata
USAnws-alertmap.jsCurrent  V1.01 - 2021-11-29V1.01 - 2021-11-291.01 - 29-Nov-2021 - add SameSite=Lax to cookie test
USAnws-alerts-details-inc.phpCurrent  V1.09 - 2024-04-01V1.09 - 2024-04-01nws-alerts-details-inc.php - V1.09 - 01-Apr-2024
USAnws-alerts-log.phpCurrent  V1.02 - 2023-05-13V1.02 - 2023-05-131.02 - 13-May-2023 - PHP8+ adjustments
USAnws-alerts-summary-inc.phpCurrent  V1.02 - 2018-01-27V1.02 - 2018-01-271.02 - 27-Jan-2018 - updates for PHP7+ and nws-alerts V1.42
USAnws-alerts.cssCurrent  V2.02 - 2019-05-14V2.02 - 2019-05-142.02 - 14-May-2019 - initial nws-alerts.css with Leaflet/OpenStreetMaps replacing Google maps
USAnws-alerts.phpCurrent  V2.00 - 2024-01-30V2.00 - 2024-01-30nws-alerts.php - V2.00 - 30-Jan-2024
USAnws-all-zones-inc.phpCurrent  V1.04 - 2024-03-05V1.04 - 2024-03-051.04 - 05-Mar-2024 - NWS updates (March 5, 2024) for zones
USANWS-regional-radar-animate.phpCurrent  V1.04 - 2022-01-18V1.04 - 2022-01-18NWS-regional-radar-animate.php - V1.04 - 18-Jan-2022
Commonplaintext-parser-data.txtCurrent  V1.06 - 2011-01-01V1.06 - 2011-01-011.06 - 01-Jan-2011
Commonplaintext-parser.phpCurrent  V1.31 - 2018-11-30V1.31 - 2018-11-30plaintext-parser.php Version 1.31 - 30-Nov-2018
Commonquake-json.cssCurrent  V3.00 - 2019-05-13V3.00 - 2019-05-133.00 - 13-May-2019 - added esri markups needed
Commonquake-json.jsCurrent  V1.01 - 2020-07-07V1.01 - 2020-07-071.01 - 07-Jul-2020 - fixed window.onload issue with sorttable V2
Commonquake-json.phpCurrent  V3.03 - 2020-06-30V3.03 - 2020-06-30quake-json.php V3.03 - 30-Jun-2020
USAradar-status.phpCurrent  V1.20 - 2022-12-27V1.20 - 2022-12-27radar-status.php V1.20 - 27-Dec-2022
Commonthermometer.phpCurrent  V1.19 - 2022-12-27V1.19 - 2022-12-271.19 - 27-Dec-2022 - fixes for PHP 8.2
USAUSA-regional-maps-inc.phpCurrent  V1.05 - 2023-12-11V1.05 - 2023-12-111.05 - 11-Dec-2023 - use WU-satellite-animate.php for right map if available
WCT-pluginWCT-defs.phpCurrent  V1.01 - 2012-03-25V1.01 - 2012-03-25WCT-defs.php - V1.01 - 25-Mar-2012
WCT-pluginWeatherCat-webtags.txtCurrent  Vn/a - 2012-03-24Vn/a - n/a(not specified)
DeprecatedWU-radar-inc.phpOk to delete from website.DeleteWU-radar-inc.php is deprecated.
DeprecatedWU-radar-testpage.phpOk to delete from website.DeleteWU-radar-testpage.php is deprecated.
USAWU-satellite-animate.phpNeed update to
V1.01 - 2024-01-11
ReplaceV1.01 - 2024-01-11V1.00 - 2023-12-11WU-satellite-animate.php - V1.00 - 11-Dec-2023
USAwxadvisory.phpCurrent  V1.05 - 2024-01-30V1.05 - 2024-01-301.05 - 30-Jan-2024 - fixes to deprecate atom-advisory.php
Commonwxforecast.phpCurrent  V1.09 - 2023-05-18V1.09 - 2023-05-181.09 - 18-May-2023 - added styling for EC 'advisory' alert
Commonwxgraphs.phpCurrent  V1.07 - 2021-05-14V1.07 - 2021-05-141.07 - 14-May-2021 - added WeeWX graphs support
Commonwxmetar.phpCurrent  V1.01 - 2011-11-27V1.01 - 2011-11-271.01 - 27-Nov-2011 - display 'Distance to station' mods
USAwxnws-alerts-log.phpCurrent  V1.02 - 2023-05-13V1.02 - 2023-05-131.02 - 13-May-2023 - fix for errata when $daily_log = NULL, add downloader
USAwxnws-details.phpCurrent  V1.02 - 2019-05-14V1.02 - 2019-05-141.02 - 14-May-2019 - updated for Leaflet/OpenStreetMaps
USAwxnwsradar-iframe.phpCurrent  V2.03 - 2024-02-15V2.03 - 2024-02-152.03 - 15-Feb-2024 - sanitize $_POST inputs to fix XSS vulerability (Thanks dwhitemv on WXForum.net)
USAwxnwsradar-inc.phpCurrent  V2.03 - 2024-02-15V2.03 - 2024-02-152.03 - 15-Feb-2024 - sanitize $_POST inputs to fix XSS vulerability (Thanks dwhitemv on WXForum.net)
USAwxnwsradar.phpCurrent  V2.03 - 2024-02-15V2.03 - 2024-02-152.03 - 15-Feb-2024 - sanitize $_POST inputs to fix XSS vulerability (Thanks dwhitemv on WXForum.net)
Commonwxquake.phpCurrent  V3.00 - 2019-11-13V3.00 - 2019-11-133.00 - 13-Nov-2019 - generalized for optional dislay of faults/tectonic plates from multiple sources

To update your template set to current script version(s), use the updates tool page with a query set for 03-Apr-2023 for Base-USA, WCT-plugin

PHP Version 7.4.33
Memory post_max_size 8M bytes.
Memory usage 1224696 bytes.
Memory peak usage 2199160 bytes.